skip to Main Content
WARNING: WordPress 5.5 Update Breaking Sites

WARNING: WordPress 5.5 Update Breaking Sites

ATTN WEBSITE OWNERS: If you run a WordPress website, be aware that the latest version (5.5) has some serious issues. Apparently there is a deprecated jQuery function that breaks a wide variety of plugins and even basic editing functions…

Clearly whoever authorized this garbage release wants to force everyone to use Gutenberg (their extremely buggy and lackluster page builder) instead of the Classic editor or other (real) page builders like WPbakery, Elementor, Divi, etc.

Solution 1: Stick with WordPress 5.4.2 until they patch this beyond 5.5.

Solution 2: If you have already updated to 5.5 and are experiencing errors, check out this article about the Enable jQuery Migrate Helper plugin (I’ve yet to verify this solution myself, but it’s a good start) …

After installing WordPress version 5.5, many bloggers and website owners have been reporting problems with the number of plugins installed in their CMS, prominently Classic Editor and Yoast, which happens to be among the most-installed WordPress plugins worldwide. Many website owners have vented their frustration with WordPress version 5.5 on official forums.

The update essentially left the WP admin panel broken for a significant number of website owners. Following the installation, pull-downs and pop-ups would stop working, as also experienced by TheWindowsClub authors. Apart from Yoast, the update also ended up breaking the Classic WordPress Editor plugin for us.

Back To Top